Gem install do sqlite3 error



Problem installing sqlite3-ruby!

I’m having issues installing the sqlite3-ruby gem on crunchbang linux. After googling the past few hours and following several people with the same problem, I still haven’t gotten it to work.

Here is what I see after trying a ‘sudo gem install sqlite3-ruby’

Building native extensions. This could take a while.
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
checking for sqlite3.h. yes
checking for sqlite3_libversion_number() in -lsqlite3. yes
checking for rb_proc_arity(). no
checking for sqlite3_initialize(). no
sqlite3-ruby only supports sqlite3 versions 3.6.16+, please upgrade!
* extconf.rb failed *
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

I downloaded sqlite-amalgamation-3.7.0.1.tar.gz and issued the following commands:

tar zxvf sqlite-amalgamation-3.7.0.1.tar.gz
cd cd sqlite-3.7.0.1
mkdir $HOME/sqlite
./configure —prefix=$HOME/sqlite
make && make install
sudo gem install sqlite3-ruby — —with-sqlite3-dir=$HOME/sqlite

However, I still get the exact same error. I’ve used ‘sudo apt-get install sqlite3 libsqlite3-dev’ but I still get the exact same error.

And as a small aside, how come when I use ‘sudo apt-get install sqlite3’, it grabs 3.5.9 instead of the 3.7.0.1 I manually downloaded?

Источник

Читайте также:  Error in script lcpdfr loader
Оцените статью
toolgir.ru
Adblock
detector