Interface wifi0 high error rate



Zabbix 5 — что не так с извещениями в Telegram?

По руководству был настроен бот, тест сообщений в чат проходил, даже сообщения отправлялись. После этого была сделана попытка подкрутить шаблоны сообщений, в т.ч. вставить эмодзи. И всё сломалось. А сейчас даже тест сообщений не проходит.

Если убрать скобочки, тест проходит. Но в реальных сообщениях разных символов, в том числе ‘-‘ , ‘(‘ и т.п. дофига и все эти сообщения оседают в Action Log.

Ну, и чтоб 2 раза не вставать — как например в subject сообщения вставить эмодзи, например, SOS с кодом \xF0\x9F\x86\x97 ? Маркдаун :sos: тоже не срабатывает. Если попытаться вставить сам символ, то ругается при уже сохранении страницы Media Type.

  • Вопрос задан более двух лет назад
  • 1973 просмотра

Эмоджи можно определять как Unicode Surrogates (вида `\u01234\uABCD` )

Тогда в JS-скрипте отправки сообщения в телеграм надо 29-ю строку вида
data = JSON.stringify(params);
заменить на

Суть в том, что JSON.stringify экранирует все слэши в Surrogates, получается два слэша. Поэтому, после того, как получили JSON с data для отправки надо вернуть один слэш и это изменение делаем только для Unicode Surrogates, а не вообще по тексту. Регулярка в помощь.

единственное, не все проходят, возможно, UTF16 не годятся.
У меня такие подошли ✅ ‼️ ⚠️

По умолчанию поле Parsemode пустое. Попробуйте очисти поле «Parsemode»

Я не просил перевести текст, это я отлично понимаю. Пару дней назад это проходило

Источник

подскажите, в чем может быть причина огромного числа дропнутых пакетов на rx?

kettle

новичок

Две точки NanoBeam 5AC 19 работают в режиме моста, расстояние где-то около километра с небольшим.
В какой-то момент вдруг резко просела скорость «интернета», путем легкого ковыряния выяснилось, что пинг от точки до точки теряет порядка 10% пакетов.

вот пример, сейчас трафика почти нет, в мониторе показывается TX/RX около 100-150kbps.
Запускаю скачивать iso с mirror.yandex.ru и получаю такую картину:
wget показывает скорость порядка 1,2-2,0M/s ,
в веб-интерфейсе в то же самое время RX: 15-30Mbps,
пинг с точки на точку:
100 packets transmitted, 79 packets received, 21% packet loss
round-trip min/avg/max = 0.839/47.257/574.844 ms

И это не загруженность процессора точки, поскольку с компа пинг ближней точки:
100 packets transmitted, 100 received, 0% packet loss, time 99004ms
rtt min/avg/max/mdev = 0.132/0.190/1.942/0.241 ms

и пинг дальней точки:
100 packets transmitted, 82 received, 18% packet loss, time 100230ms
rtt min/avg/max/mdev = 1.552/47.777/562.468/93.997 ms

Различия видны сразу. И в потерях, и в лагах.

Статистика по интерфейсам ближней точки показывает следующее (набежало за 4,5 часа)

ath0
RX packets:1312916 errors:0 dropped:0 overruns:0 frame:0
TX packets:842977 errors:12020 dropped:30 overruns:0 carrier:0
collisions:0 txqueuelen:0

eth0
RX packets:919867 errors:0 dropped:3348 overruns:0 frame:0
TX packets:1365119 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000

wifi0
RX packets:1823124 errors:0 dropped:578713 overruns:0 frame:0
TX packets:1202825 errors:0 dropped:1424 overruns:0 carrier:0
collisions:0 txqueuelen:447

Device information ближней точки:

Memory: 30%
CPU: 12%
airMAX Quality: 80%
airMAX Capacity: 5%
Frequency: 5785 MHz
Channel Width: 40 MHz
Distance: 0.7 miles (1.1 km)
Signal: -66 dBm
Chain 0 / Chain 1: -69 / -70 dBm
Remote Signal: -70 dBm
Remote Chain 0 / Chain 1: -80 / -70 dBm
Connections: 1
Noise Floor: -93 dBm
TX/RX Bytes: 215M / 1.59G
Remote TX Power: 17 dBm

Читайте также:  Sql error 1046 3d000 no database selected dbeaver

AMС прыгает от 5% до 30%,
AMQ порядка 80-85%.
Уровни сигнала изменяются в пределах +-1 от указанных.

Хотелось бы понять следующее:
чем вызвано такое недетское число дропнутых пакетов на wifi0 интерфейсе?
что делать с жуткими потерями на радиоканале?
что делать с очень низким AMC?

Мне в голову приходит только два варианта: либо одну из точек свернули в сторону, либо стоящая на крыше многоэтажки точка по нынешней московской погоде на ветру просто обмерзает и это сказывается на сигнале.
Или есть какие-то еще причины?

Источник

Wireless Packet Info — RX/TX Errors

From DD-WRT Wiki

[edit] Wireless Packet Info

In my wrt54g if i chose the right antenna for reception and the left one for transmiision the number of error fell even if i use my bluetooth headset

[edit] How can one avoid all these errors?

  • Do a site survey under Status -> Wireless and find out what channels in your area are NOT being used and set it in your Wireless Basic configuration. Also setting the wireless Channel to Auto will dynamically config the channel and channel width. Much more user friendly feature for basic users.
  • Selecting an unused channel works, but one must choose a channel that is two channels (10Mhz) separated from the the adjacent occupied channel. There will still be interference with one channel separation.
  • If you see the RX errors constantly increasing regardless of network traffic, try the ‘wl interference 2’ command (via the Admin→Commands interface). This forces Wireless LAN interference mitigation to be enabled. The default of 3 (automatic) might be failing to activate despite the AP being in a heavily WiFi congested area. If this helps, you can save the command to be run automatically at boot time using the «Save Startup» button. (See also Startup Scripts.)
  • The bottom line is that the high RX error rate is due to Radio interferences from neighboring Wi-Fi, Bluetooth, Cordless phones, Cellular phones, Speakers, Microwave Ovens, Fans, and even Florescent lamps. If this is happening to your AP, you may want to tweak the Channel, Bluetooth coexistence mode, and dissociate the AP from any sources of interference.

[edit] Another important Aspect

Placing the router in the highest area possible is essential, as this will provide greater radio coverage.

For routers with external antennas, orientation of the antenna(s) is very important.

  • For Single antenna models, it should be placed 90° (L Shaped) with respect to the flat side of the router.
  • For Dual antenna models, the orientation should be 120° (V Shaped) with respect to the flat side of the router.
  • For Multiple antenna models, they should be oriented at 45°. (W Shaped) For example, on an Asus WL500W the middle antenna should be angled at 90°, and the other antennas should be separated at 45° angles.
Читайте также:  Ajax error вывод ошибок

Источник

Отваливаются точки

Razumka

участник

Периодически бывает что клиенты отваливаются, и на точке вот такая картина, TX сигнал показывает как прочерк, перезагрузишь точку, вроде норм какоето время, логики такого поведения не нашел.

fAntom

Super Moderator

Serct

участник

Помогите!
AirFiber 5U пропадает радиоканал, как определить с какой стороны отключается.
Ранее всё работало , но вот по какой то причине со вчерашнего утра периодически начало пропадать сигнал с видеокамер стоящих на конечной точке.

У меня на здании стоит Slave, далее идущий на Master, а с него уже сигнал пробрасывает на Microtik NetMetal5 где и стоят видеокамеры. На Slave пинг идёт великолепный 1-2 мс(кабеля всего 10 метров), а вот на Master уже чаще отваливается радиоканал чем находится в коннекте. Если появляется радиоканал между Slave и Master, то видеокамеры сразу начинают работать, и пингуются нормально 3-7 мс , значит радиоканал падает именно между Slave и Master. Когда канал работает, то пингуется нормально в обе стороны и Slave и Master.

Помогите определить с какой стороны отключается радиоканал, есть ли методы тестирования? И вообще как узнать причины пропадания канала. Где смотреть, куда залезть. Может передатчик на Slave выделывается, почему если пропал радиоканал, то пропадают Chain 0 и Chain 1 и на Slave , по идее это же моя сторона, она великолепно пингуется, и должна что то пытаться передать, или если нет канала, то и не покажет мощность сигнала на моей стороне?

Вложения

Provider

участник

Помогите!
AirFiber 5U пропадает радиоканал, как определить с какой стороны отключается.
Ранее всё работало , но вот по какой то причине со вчерашнего утра периодически начало пропадать сигнал с видеокамер стоящих на конечной точке.

У меня на здании стоит Slave, далее идущий на Master, а с него уже сигнал пробрасывает на Microtik NetMetal5 где и стоят видеокамеры. На Slave пинг идёт великолепный 1-2 мс(кабеля всего 10 метров), а вот на Master уже чаще отваливается радиоканал чем находится в коннекте. Если появляется радиоканал между Slave и Master, то видеокамеры сразу начинают работать, и пингуются нормально 3-7 мс , значит радиоканал падает именно между Slave и Master. Когда канал работает, то пингуется нормально в обе стороны и Slave и Master.

Помогите определить с какой стороны отключается радиоканал, есть ли методы тестирования? И вообще как узнать причины пропадания канала. Где смотреть, куда залезть. Может передатчик на Slave выделывается, почему если пропал радиоканал, то пропадают Chain 0 и Chain 1 и на Slave , по идее это же моя сторона, она великолепно пингуется, и должна что то пытаться передать, или если нет канала, то и не покажет мощность сигнала на моей стороне?

Вложения

Serct

участник

Спасибо за ответ, меня интересовали методы диагностики работоспособности радиомоста , как проверить к примеру если вышел из строя приёмник или передатчик на одной из точек. Скринов удалённого конца не мог сделать так как не было возможности проехать туда(пурга 2 недели, находимся на крайнем севере), логи мои предшественники не включали, всё работало до определённого момента(значит все настройки были в норме) а перед пургой, за 6 часов стал периодически пропадать радиоканал, место где стоит удалённая точка в тот момент была закрыта облаком, облако к утру ушло а радиоканал так и не заработал, ну а к обеду началась пурга. Начальник орёт, почему и как могло перестать работать, а мои предположения и догадки его не устраивали, требовалась точная диагностика работоспособности хотя бы ближней точки, я к ней лазил на мачту, внешне никаких признаков поломок не обнаружил, диагностика методом пингования его не устраивала. Вот и задал на форуме вопрос о методах проверки работоспособности разных узлов AirFiber 5U.

Читайте также:  C free function error

Причина оказалась проста, точку залепило мокрым снегом , а потом ударил мороз и образовалась толстая корка плотного снега, на ощупь как пирожное «безе», лёгкий но твёрдый. На мачте 4 антенны, об их местонахождении можно только догадываться.

Источник

Question High Error Output on Trunk Interface — Help Troubleshooting

matiasht

Distinguished

Hello everyone, new to the forum here!

We have three switches in our company, one of them is the core switch, and the other two is where our client PCs are connected. The switch core also has an ESXi Server connected to it, where all of our services are hosted. Additionally, we have a Cisco ASA Firewall connected to it. In order to monitor our interfaces and other devices/servers, we use Zabbix 4.0.

Everything was working normally, we hired +35 people, and everything is practically the same, however, we are getting alerts on Zabbix about high error rate on output interface Gi 1/0/22, this is one of the trunk ports which is connected to one of our non-core switches where end users are connected to. Sometimes we also receive alerts for interface 1/1/2 which is where our outside interface on the Cisco ASA is connected to, this last one goes away after some minutes, and it only pops-up from time to time.

However, our Gi 1/0/22 alert stays there for over an hour, then it goes away, and re-appears. The cabling of these interfaces was changed two days ago on a schedule where no people was working. The alert still pops up however reducing from an hour to 25-30 minutes. So, that might be an improvement, but I am still concerned about the alert. What other options do we have in order to troubleshoot this issue? Should I post an image of our interface?

I’d be eternally thankful for the help!

jsmithepa

Glorious

So did this EVER worked right, or did you just inherited this situation?

Both boxes in the same room? (cable length issue), is trunk link optical? (blow out dust on connectors). May wanna open the boxes and give it a good vacuum, note dead fan(s) (heat issue).

After that u may have a failing switch(es). Even solid state can fail.

Источник

Оцените статью
toolgir.ru
Adblock
detector