Openal device error a004



Openal device error a004

I use the most recent kernel of Arch Linux (x86_64 Linux 4.2.5-1-ARCH)

Microsoft.Xna.Framework.Audio.NoAudioHardwareException: External exception
at Microsoft.Xna.Framework.Audio.AudioDevice.GenBuffer (System.Byte[] data, UInt32 sampleRate, UInt32 channels, UInt32 loopStart, UInt32 loopEn$
at Microsoft.Xna.Framework.Audio.SoundEffect..ctor (System.String name, System.Byte[] buffer, UInt32 sampleRate, UInt32 channels, UInt32 loopSt$
at Microsoft.Xna.Framework.Audio.WaveBank.LoadWaveEntry (Microsoft.Xna.Framework.Audio.SoundStreamEntry entry, UInt16 track, System.IO.BinaryRe$
at Microsoft.Xna.Framework.Audio.WaveBank.LoadWaveBank (Microsoft.Xna.Framework.Audio.AudioEngine audioEngine, System.IO.BinaryReader reader, B$
at Microsoft.Xna.Framework.Audio.WaveBank..ctor (Microsoft.Xna.Framework.Audio.AudioEngine audioEngine, System.String nonStreamingWaveBankFilen$
at Apotheon.ScreenManager.LoadGameContent () [0x00000] in :0
at Apotheon.Start.Initialize () [0x00000] in :0
at Microsoft.Xna.Framework.Game.DoInitialize () [0x00000] in :0
at Microsoft.Xna.Framework.Game.Run () [0x00000] in :0
at Apotheon.Program.Main (System.String[] args) [0x00000] in :0

OpenAL isn’t finding any audio hardware on your box — you’ll need to either find out why it’s not finding any devices, or use this environment variable to get around it:

Источник

166: OpenAL Error (A003): invalid value, line 213 #184

Comments

OpenAL Error (A003): invalid value, line 213 by alan.ott.jr
Issue 166 posted to Google Code on 2014 Jul 28 at 02:41:15

Current status: Invalid
Current labels: Type-Defect , Priority-Critical , Usability

alan.ott.jr on 2014 Jul 28 at 02:41:15:

What steps will reproduce the problem?
1.I play any game mode
2.Any Online server or offline
3.It will play for a 10-15 mins then crash

What is the expected output? What do you see instead?

Straight from the console.

What version are you using? On what operating system?

[1.0 Base] 2.6 New Year. Ubuntu 14.04LTS 64-bit

Please provide any additional information below.

PC Build
Intel® Core™2 Quad CPU Q9550 @ 2.83GHz × 4
GeForce GTX 560 Ti/PCIe/SSE2 Driver version 331.38
7.8 GiB Ram

Screenshot from 2014-07-27 22-29-15.png

theonlypwner on 2014 Jul 29 at 03:36:06:

Labels: -Priority-Unset Priority-Critical Usability
Status: Started-Redo

theonlypwner on 2014 Aug 23 at 01:41:51:

This issue is one of those assumed to affect version 2.6 and previous versions.

Status: Invalid

The text was updated successfully, but these errors were encountered:

Источник

Openal device error a004

After the last major patch, and the move to FNA (with alternate XNA branch), almost all previous known issues are fixed, so i’m retiring the old bug thread and starting a new one. Read through the known issues list below before posting!
Old thread here.

Please include screenshots of the background terminal and your screen for bug reports! If applicable, also include your save file (My Documents/My Games/Hacknet/Accounts) and any crash reports (My Documents/My Games/Hacknet/Reports). Bugs that are well documented, have screenshots, saves, or any other information, and can give me a lot to work off will be fixed first (and sooner!). Describe the situation as thoroughly as you can..

Thanks for all your help!
-Matt

Sorry to say, but there seems to be no «reports» folder in the specified area (everything about file saving and such is left at default)

It’s not a huge problem, but I open up the game, it freezes for a bit, then I can click on «continue». The game then crashes shortly after starting the game.

But then I open it up again, no freezing, and the game starts normally again, as I said, not a big issue, but just a heads up and stuff.

I couldn’t take screenshots of the background terminal, since. well, it closed out as soon as the game crashed. heh

The only thing I can provide is my specs:

Intel HD Graphics Family
Intel i5 quad core
6GB RAM

I hope I helped, at least some.

Sorry to say, but there seems to be no «reports» folder in the specified area (everything about file saving and such is left at default)

It’s not a huge problem, but I open up the game, it freezes for a bit, then I can click on «continue». The game then crashes shortly after starting the game.

But then I open it up again, no freezing, and the game starts normally again, as I said, not a big issue, but just a heads up and stuff.

I couldn’t take screenshots of the background terminal, since. well, it closed out as soon as the game crashed. heh

The only thing I can provide is my specs:

Intel HD Graphics Family
Intel i5 quad core
6GB RAM

I hope I helped, at least some.

Hmm, I still can’t hear any music playing regardless of setting WMP as the system default media app. Other sound fx are playing back fine.

Win10 Pro x64 + Creative SB X-fi sound card. It worked fine when I bought it back in Aug. last year on this same OS / hardware combination; I’m not sure what happened.

Читайте также:  Error png c readpngimage

2/10/16 — Update: Got the music working now. Yup, user error. My bad.

Hmm, I still can’t hear any music playing regardless of setting WMP as the system default media app. Other sound fx are playing back fine.

Win10 Pro x64 + Creative SB X-fi sound card. It worked fine when I bought it back in Aug. last year on this same OS / hardware combination; I’m not sure what happened.

I’m getting an odd bug that could contain spoilers. Bug follows:

Whenever I run the command: > DECHead CSEC_encode_1.dec the GUI pops up Loading, then scrolls to Complete for all of the items. However, in the console, it infinitely posts «DEC Encrypted File CSEC_encode_1.dec headers: ————Header Analysis Complete————

Am I missing something gameplay related, or is this a bug?

I’m getting an odd bug that could contain spoilers. Bug follows:

Whenever I run the command: > DECHead CSEC_encode_1.dec the GUI pops up Loading, then scrolls to Complete for all of the items. However, in the console, it infinitely posts «DEC Encrypted File CSEC_encode_1.dec headers: ————Header Analysis Complete————

Am I missing something gameplay related, or is this a bug?

Hi, I have a problem with the S1 or s1 command to navigate in the game when i’ve hacked in to a computer or other device. Cant seem to find enyone else having this problem, it just says «no command — s1 check syntax»

OS: Windows 10 x64

Hi, I have a problem with the S1 or s1 command to navigate in the game when i’ve hacked in to a computer or other device. Cant seem to find enyone else having this problem, it just says «no command — s1 check syntax»

my game crashes when loaded and comes up with the crash report: System.UnauthorizedAccessException

Access to the path ‘C:\Users\_______\Documents/My Games/Hacknet/Accounts/’ is denied.

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object
dirSecurityObj, Boolean checkHost)

at System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
at System.IO.Directory.CreateDirectory(String path)
at Hacknet.PlatformAPI.Storage.LocalDocumentsStorageMethod.WriteFileData(String filename,
String data)

at Hacknet.PlatformAPI.Storage.SaveFileManifest.Save(IStorageMethod storage)
at Hacknet.PlatformAPI.Storage.LocalDocumentsStorageMethod.Load()
at Hacknet.PlatformAPI.Storage.SaveFileManager.Init()
at Hacknet.Game1.LoadContent()
at Microsoft.Xna.Framework.Game.Initialize()
at Hacknet.Game1.Initialize()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Hacknet.Program.Main(String[] args)System.UnauthorizedAccessException: Access to the
path ‘C:\Users\Lewis\Documents/My Games/Hacknet/Accounts/’ is denied.

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object
dirSecurityObj, Boolean checkHost)

at System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
at System.IO.Directory.CreateDirectory(String path)
at Hacknet.PlatformAPI.Storage.LocalDocumentsStorageMethod.WriteFileData(String filename,
String data)

at Hacknet.PlatformAPI.Storage.SaveFileManifest.Save(IStorageMethod storage)
at Hacknet.PlatformAPI.Storage.LocalDocumentsStorageMethod.Load()
at Hacknet.PlatformAPI.Storage.SaveFileManager.Init()
at Hacknet.Game1.LoadContent()
at Microsoft.Xna.Framework.Game.Initialize()
at Hacknet.Game1.Initialize()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Hacknet.Program.Main(String[] args)

OS INSTANCE NULL

Please include screenshots of the background terminal and your screen for bug reports! If applicable, also include your save file (My Documents/My Games/Hacknet/Accounts) and any crash reports (My Documents/My Games/Hacknet/Reports). Bugs that are well documented, have screenshots, saves, or any other information, and can give me a lot to work off will be fixed first (and sooner!). Describe the situation as thoroughly as you can.

I’m using the mv command here to move a file from one directory to another. Many times I’ve seen that it is successfully renaming the file to the name I would like it to be in the target directory BUT it does not actually move the file to that directory, instead it gives me a «file not found» error.

Источник

OpenAL Error crash #215

Comments

The game crashed after few games :

I also have multiple error messages :
libpng warning: iCCP: known incorrect sRGB profile
OpenAL Error (A003): invalid value, line 156

The text was updated successfully, but these errors were encountered:

What version of ACR are you using?

Without debug symbols, there is not enough information to identify the problem. Does the crash also happen if you compile ACR (as native_client )?

I’m using the precompiled Linux release 2.7.
Maybe I should compile it myself

Please test with a self-compiled binary.
It would be the best if we can get a log with references to line numbers in the code.

This issue seems to persist in later versions.

That happens to me since I installed Arch.

I think a stack trace may help you fixing the issue, so
I tried to run a self-compiled binary and I got the following stack trace:

Please run addr2line to get the corresponding source code line numbers.

I would guess you’d run something like addr2line -f -i -e

/acr/bin_unix/native_client 0x12577f for each line with /acr/bin_unix/native_client in the stacktrace.

If the root cause is in a dependency library, you might need to figure out the line numbers for the libraries and report the issue to the library maintainers.

Читайте также:  Что это код ошибки system service exception windows

Interestingly, in #250, a duplicate of this issue, @Mte90 found that compiling the game himself made the crash seem to disappear. This suggests the root cause could be a bug in one of the dependencies.

In #168, jamese946 on Google Code said it might be a bug in the OpenAL project.

It’s an OpenAL error specific to Linux machines, it seems. It pretty much rendered the game unplayable on Arch. The error occurs on Ubuntu, but not at the same frequency.

Just a heads up, devs.

#189 seemed to be due to an infinite loop in AC’s bot code that keeps allocating with new , but it might also be related

Please run addr2line to get the corresponding source code line numbers.

I don’t think it worked, but here’s the output:

Источник

openal detection issues #118

Comments

On GNU/Linux wxlauncher is not linked with openal — instead a silly run-time detection is performed in code/apis/OpenALManager.cpp.

This may be a reason for the following run-time error on start:

The text was updated successfully, but these errors were encountered:

Please provide the wxLauncher.log from a debug build (if the issue is reproducible using one) showing the issue. The launcher always produces a log at

/.wxlauncher/wxLauncher.log. That error however means that openal was detected using the runtime detection and that you probably just haven’t selected a playback device

The run-time detection is performed mostly for Windows, where package management and dependency management is not performed by the system and where (until recently at least) Creative’s non-redistributable version was the default.

On start it logs:

When I select the only device from drop-down list in Basic Settings —> Audio —> Playback device:

On Unix systems run-time selection of library is a time bomb not to mention that such approach is incorrect.

Indeed. However, since you have entries in the drop down. It did find the library at runtime, so that is not the issue. I need the wxLauncher.log to help further.

There is nothing else in the apart from

on start and the following on exit:

Please create a debug build by adding -DCMAKE_BUILD_TYPE=Debug when running cmake, and try running the resulting build. You will get a much longer log.

Well, debug build is actually crashing due to #117:

If I make Debug build with «-DNDEBUG» then there is nothing more to the log than what I already provided.

Hmm. -DNDEBUG turns off the runtime checks, so that is not a surprise. Lets see if we can make it rung without -DNDEBUG . I have pushed 23d96d3 to try and fix more of them. If you get any more assertions, please include the stacktrace, so that I can find the call that is triggering them.

I already applied 23d96d3 and reported new backtrace in #117. Please let me know if there is anything else I can do.

OK, I had to manually apply changes from 1809018 as your version slightly diverged from 0.9.6 branch. Now I’m getting the following backtrace:

ConvertedBuffer /usr/include/wx-3.0/wx/string.h:3490 [3]

ConvertedBuffer /usr/include/wx-3.0/wx/string.h:3490 [4] MainWindow::MainWindow() /mnt/tmpssd/src/wxlauncher/wxlauncher-release-0.9.5/code/MainWindow.cpp:77 [5] wxLauncher::OnInit() /mnt/tmpssd/src/wxlauncher/wxlauncher-release-0.9.5/code/wxLauncherApp.cpp:248 [6] wxEntry(int&, wchar_t**) [7] main /mnt/tmpssd/src/wxlauncher/wxlauncher-release-0.9.5/code/wxLauncherApp.cpp:50 [8] __libc_start_main [9] _start»>

Can you try building the 0.9.6 branch from my repo. It is only big fixes for the 0.9.5 release.

I cannot repro this issue on my Debian Jessie machine. Is your build machine different from than a Jessie machine installed from the Jessie install media?

That’s pretty much what I build. I just tried again with your branch 0.9.6 exactly and got the same run-time crash. I usually build in clean «unstable» chroot but on Jessie it is the same. I’m on amd64.

Can you please attached the CmakeCache.txt file that you are using?

On Wed, 18 Mar 2015 21:45:39 IssMneur wrote:

Can you please attached the CmakeCache.txt file that you are using?

This is the CMakeCache file.

For build in directory: /mnt/tmpssd/src/wxlauncher/wxlauncher-release-0.9.5/obj-x86_64-linux-gnu

It was generated by CMake: /usr/bin/cmake

You can edit this file to change values found and used by cmake.

If you do not want to change any of the values, simply exit the editor.

If you do want to change a value, simply edit, save, and exit the editor.

The syntax for the file is as follows:

KEY:TYPE=VALUE

KEY is the name of a variable in the cache.

TYPE is a hint to GUIs for the type of VALUE, DO NOT EDIT TYPE!.

VALUE is the current value for the KEY.

EXTERNAL cache entries

//Path to a program.
CMAKE_AR:FILEPATH=/usr/bin/ar

Читайте также:  Error response from daemon rpc error code deadlineexceeded desc context deadline exceeded

//Choose the type of build, options are: None(CMAKE_CXX_FLAGS or
// CMAKE_C_FLAGS used) Debug Release RelWithDebInfo MinSizeRel.
CMAKE_BUILD_TYPE:STRING=Debug

//Enable/Disable color output during build.
CMAKE_COLOR_MAKEFILE:BOOL=ON

//CXX compiler.
CMAKE_CXX_COMPILER:FILEPATH=/usr/lib/ccache/c++

//Flags used by the compiler during all build types.
CMAKE_CXX_FLAGS:STRING=’-g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 ‘

//Flags used by the compiler during debug builds.
CMAKE_CXX_FLAGS_DEBUG:STRING=-g

//Flags used by the compiler during release builds for minimum
// size.
CMAKE_CXX_FLAGS_MINSIZEREL:STRING=-Os -DNDEBUG

//Flags used by the compiler during release builds.
CMAKE_CXX_FLAGS_RELEASE:STRING=-g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2

//Flags used by the compiler during release builds with debug info.
CMAKE_CXX_FLAGS_RELWITHDEBINFO:STRING=-O2 -g -DNDEBUG

//C compiler.
CMAKE_C_COMPILER:FILEPATH=/usr/lib/ccache/cc

//Flags used by the compiler during all build types.
CMAKE_C_FLAGS:STRING=’-g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 ‘

//Flags used by the compiler during debug builds.
CMAKE_C_FLAGS_DEBUG:STRING=-g

//Flags used by the compiler during release builds for minimum
// size.
CMAKE_C_FLAGS_MINSIZEREL:STRING=-Os -DNDEBUG

//Flags used by the compiler during release builds.
CMAKE_C_FLAGS_RELEASE:STRING=-O3 -DNDEBUG

//Flags used by the compiler during release builds with debug info.
CMAKE_C_FLAGS_RELWITHDEBINFO:STRING=-O2 -g -DNDEBUG

//Flags used by the linker.
CMAKE_EXE_LINKER_FLAGS:STRING=-Wl,—as-needed -Wl,-z,relro -Wl,-z,now

//Flags used by the linker during debug builds.
CMAKE_EXE_LINKER_FLAGS_DEBUG:STRING=

//Flags used by the linker during release minsize builds.
CMAKE_EXE_LINKER_FLAGS_MINSIZEREL:STRING=

//Flags used by the linker during release builds.
CMAKE_EXE_LINKER_FLAGS_RELEASE:STRING=

//Flags used by the linker during Release with Debug Info builds.
CMAKE_EXE_LINKER_FLAGS_RELWITHDEBINFO:STRING=

//Enable/Disable output of compile commands during generation.
CMAKE_EXPORT_COMPILE_COMMANDS:BOOL=OFF

//Install path prefix, prepended onto install directories.
CMAKE_INSTALL_PREFIX:PATH=/usr

//Path to a program.
CMAKE_LINKER:FILEPATH=/usr/bin/ld

//Path to a program.
CMAKE_MAKE_PROGRAM:FILEPATH=/usr/bin/make

//Flags used by the linker during the creation of modules.
CMAKE_MODULE_LINKER_FLAGS:STRING= -Wl,-z,relro -Wl,-z,now

//Flags used by the linker during debug builds.
CMAKE_MODULE_LINKER_FLAGS_DEBUG:STRING=

//Flags used by the linker during release minsize builds.
CMAKE_MODULE_LINKER_FLAGS_MINSIZEREL:STRING=

//Flags used by the linker during release builds.
CMAKE_MODULE_LINKER_FLAGS_RELEASE:STRING=

//Flags used by the linker during Release with Debug Info builds.
CMAKE_MODULE_LINKER_FLAGS_RELWITHDEBINFO:STRING=

//Path to a program.
CMAKE_NM:FILEPATH=/usr/bin/nm

//Path to a program.
CMAKE_OBJCOPY:FILEPATH=/usr/bin/objcopy

//Path to a program.
CMAKE_OBJDUMP:FILEPATH=/usr/bin/objdump

//Value Computed by CMake
CMAKE_PROJECT_NAME:STATIC=wxlauncher

//Path to a program.
CMAKE_RANLIB:FILEPATH=/usr/bin/ranlib

//Flags used by the linker during the creation of dll’s.
CMAKE_SHARED_LINKER_FLAGS:STRING= -Wl,-z,relro -Wl,-z,now

//Flags used by the linker during debug builds.
CMAKE_SHARED_LINKER_FLAGS_DEBUG:STRING=

//Flags used by the linker during release minsize builds.
CMAKE_SHARED_LINKER_FLAGS_MINSIZEREL:STRING=

//Flags used by the linker during release builds.
CMAKE_SHARED_LINKER_FLAGS_RELEASE:STRING=

//Flags used by the linker during Release with Debug Info builds.
CMAKE_SHARED_LINKER_FLAGS_RELWITHDEBINFO:STRING=

//If set, runtime paths are not added when installing shared libraries,
// but are added when building.
CMAKE_SKIP_INSTALL_RPATH:BOOL=NO

//If set, runtime paths are not added when using shared libraries.
CMAKE_SKIP_RPATH:BOOL=NO

//Flags used by the linker during the creation of static libraries.
CMAKE_STATIC_LINKER_FLAGS:STRING=

//Flags used by the linker during debug builds.
CMAKE_STATIC_LINKER_FLAGS_DEBUG:STRING=

//Flags used by the linker during release minsize builds.
CMAKE_STATIC_LINKER_FLAGS_MINSIZEREL:STRING=

//Flags used by the linker during release builds.
CMAKE_STATIC_LINKER_FLAGS_RELEASE:STRING=

//Flags used by the linker during Release with Debug Info builds.
CMAKE_STATIC_LINKER_FLAGS_RELWITHDEBINFO:STRING=

//Path to a program.
CMAKE_STRIP:FILEPATH=/usr/bin/strip

//If true, cmake will use relative paths in makefiles and projects.
CMAKE_USE_RELATIVE_PATHS:BOOL=OFF

//If this value is on, makefiles will be generated without the
// .SILENT directive, and all commands will be echoed to the console
// during the make. This is useful for debugging only. With Visual
// Studio IDE projects all commands are done without /nologo.
CMAKE_VERBOSE_MAKEFILE:BOOL=ON

//Enable to build Debian packages
CPACK_BINARY_DEB:BOOL=OFF

//Enable to build NSIS packages
CPACK_BINARY_NSIS:BOOL=OFF

//Enable to build RPM packages
CPACK_BINARY_RPM:BOOL=OFF

//Enable to build STGZ packages
CPACK_BINARY_STGZ:BOOL=ON

//Enable to build TBZ2 packages
CPACK_BINARY_TBZ2:BOOL=OFF

//Enable to build TGZ packages
CPACK_BINARY_TGZ:BOOL=ON

//Enable to build TZ packages
CPACK_BINARY_TZ:BOOL=ON

//Enable to build TBZ2 source packages
CPACK_SOURCE_TBZ2:BOOL=ON

//Enable to build TGZ source packages
CPACK_SOURCE_TGZ:BOOL=ON

//Enable to build TZ source packages
CPACK_SOURCE_TZ:BOOL=ON

//Enable to build ZIP source packages
CPACK_SOURCE_ZIP:BOOL=OFF

//Doing development (cannot build installer in this mode)
DEVELOPMENT_MODE:BOOL=OFF

//Path to a program.
GIT_EXECUTABLE:FILEPATH=/usr/bin/git

//Path to a file.
OPENAL_INCLUDE_DIR:PATH=/usr/include/AL

//Path to a library.
OPENAL_LIBRARY:FILEPATH=/usr/lib/x86_64-linux-gnu/libopenal.so

//Extra verbose debug logs that include snapshots of profile contents
// at important steps while auto-save is off
PROFILE_DEBUGGING:BOOL=OFF

//Path to a program.
PYTHON_EXECUTABLE:FILEPATH=/usr/bin/python

//Path to a library.
SDLMAIN_LIBRARY:FILEPATH=/usr/lib/x86_64-linux-gnu/libSDLmain.a

//Path to a file.
SDL_INCLUDE_DIR:PATH=/usr/include/SDL

//Where the SDL Library can be found
SDL_LIBRARY:STRING=/usr/lib/x86_64-linux-gnu/libSDLmain.a;/usr/lib/x86_64-linux-gnu/libSDL.so;-lpthread

//Build launcher with joystick support?
USE_JOYSTICK:BOOL=ON

//Build launcher with OpenAL support?
USE_OPENAL:BOOL=ON

//Build launcher with speech support?
USE_SPEECH:BOOL=OFF

//Have the onlinehelpmaker.py script output debug information
onlinehelpmaker_debug:BOOL=OFF

//Have onlinehelpmaker.py produce even less output than normal
onlinehelpmaker_quiet:BOOL=ON

//Path to a program.
rpmbuild_exists:FILEPATH=/usr/bin/rpmbuild

//Location of wxWidgets library configuration provider binary (wx-config).
wxWidgets_CONFIG_EXECUTABLE:FILEPATH=/usr/bin/wx-config

//Use debug build?
wxWidgets_USE_DEBUG:BOOL=OFF

//Location of wxWidgets resource file compiler binary (wxrc)
wxWidgets_wxrc_EXECUTABLE:FILEPATH=/usr/bin/wxrc

//Value Computed by CMake
wxlauncher_BINARY_DIR:STATIC=/mnt/tmpssd/src/wxlauncher/wxlauncher-release-0.9.5/obj-x86_64-linux-gnu

//Value Computed by CMake
wxlauncher_SOURCE_DIR:STATIC=/mnt/tmpssd/src/wxlauncher/wxlauncher-release-0.9.5

Источник

Оцените статью
toolgir.ru
Adblock
detector