Pkg error code 1



BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD

Часовой пояс: UTC + 4 часа

Установка из портов. *** Error code 1

Страница 1 из 1 [ Сообщений: 11 ]
Автор Сообщение
d3rv1sh

Зарегистрирован: Ср 04 авг, 2004 2:57 pm
Сообщения: 44

Ставлю из портов xine.
На вопрос хочу ли получить KDE MENU ответил положительно. Вот что получил:

configure: error: Library requirements (glib-2.0 >= 2.0.0 gmodule-2.0 >= 2.0.0 gthread-2.0 >= 2.0.0 gconf-2.0 >= 1.1.1 bonobo-activation-2.0 >= 1.0.0 libbonobo-2.0 >= 2.0.0 ORBit-2.0 >= 2.9.0 libxml-2.0 >= 2.2.8 gnome-mime-data-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
===> Script «configure» failed unexpectedly.
Please direct the output of the failure of the make command to a file, and
then feed that file to the gnomelogalyzer, available from
http://www.freebsd.org/gnome/gnomelogalyzer.sh , which will diagnose the problem
and suggest a solution. If — and only if — the gnomelogalyzer cannot solve
the problem, report the problem to the FreeBSD GNOME team at gnome@FreeBSD.org ,
and attach «/usr/ports/devel/gnomevfs2/work/gnome-vfs-2.6.2/config.log» and
the output of the failure of the make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. an `ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/devel/gnomevfs2.
*** Error code 1

Stop in /usr/ports/devel/gnomevfs2.
*** Error code 1

Stop in /usr/ports/multimedia/libxine.
*** Error code 1

Stop in /usr/ports/multimedia/xine.

Подскажите куда смотреть.
Вобще *** Error code 1 возникает очень часто, так же не хочет ставить krusander и еще несколько программ.

evil

Зарегистрирован: Пн 16 авг, 2004 2:40 pm
Сообщения: 19

configure: error: Library requirements
Перечислены необходимые библиотеки

PKG_CONFIG_PATH
переменнмя, которая может содержать путь к требуемым библиотекам, если они находяться в нестандартном месте.

«/usr/ports/devel/gnomevfs2/work/gnome-vfs-2.6.2/config.log»
лог-файл, который пишет утилита configure. В него как раз и нужно посмотреть на предмет того, что требуется.

killdos

Зарегистрирован: Вт 21 сен, 2004 2:01 pm
Сообщения: 102
Откуда: Самара

Making: ../unxfbsd.pro/obj/parser.obj
g++32 -w -c -I. -I. -I../inc -I../inc -I../unx/inc -I../unxfbsd.pro/inc -I. -I/usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/solver/645/unxfbsd.pro/inc/stl -I/usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/solver/645/unxfbsd.pro/inc/external -I/usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/solver/645/unxfbsd.pro/inc -I/usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/solenv/unxfbsd/inc -I/usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/solenv/inc -I/usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/res -I/usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/solver/645/unxfbsd.pro/inc/stl -I/usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/solenv/inc/Xp31 -I/usr/local/jdk1.4.2/include -I/usr/local/jdk1.4.2/include/freebsd -I/usr/local/jdk1.4.2/include/bsd -I/usr/local/jdk1.4.2/include/native_threads/include -I/usr/X11R6/include -I. -I../res -I. -I/usr/X11R6/include -O -pipe -fno-for-scope -fpermissive -fno-rtti -fexceptions -fPIC -DFREEBSD -DUNX -DVCL -DGCC -DC300 -DINTEL -DGXX_INCLUDE_PATH=/usr/local/lib/gcc-lib/i386-portbld-freebsd4.10/3.2.3/include/g++-v3 -DCVER=C300 -D_USE_NAMESPACE -D_USE_NAMESPACE=1 -DX86 -DNEW_SOLAR -DSTLPORT_VERSION=450 -DOSVERSION=491000 -D_THREAD_SAFE -D_REENTRANT -D__DMAKE -DUNIX -DCPPU_ENV=gcc3 -DSUPD=645 -DBUILD=8762 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DEXCEPTIONS_ON -DCUI -DSOLAR_JAVA -DSRX645 -DMULTITHREAD -DMULTITHREAD -w -o ../unxfbsd.pro/obj/parser.o ../unxfbsd.pro/misc/parser.cxx
../unxfbsd.pro/misc/parser.cxx: In function `int yyparse()’:
../unxfbsd.pro/misc/parser.cxx:4740: syntax error before `goto’
dmake: Error code 1, while making ‘../unxfbsd.pro/obj/parser.obj’
—* TG_SLO.MK *—

ERROR: Error 65280 occurred while making /usr/ports/russian/openoffice-1.1/work/oo_1.1.1_src/idlc/source
dmake: Error code 1, while making ‘build_all’
—* TG_SLO.MK *—
*** Error code 255

Stop in /usr/ports/russian/openoffice-1.1.
*** Error code 1

Источник

BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD

Часовой пояс: UTC + 4 часа

Проблемы с pkg

Страница 1 из 2 [ Сообщений: 22 ] На страницу 1 , 2 След.
Автор Сообщение
Amaka

Зарегистрирован: Пн 14 дек, 2015 7:23 pm
Сообщения: 26
Откуда: Russia, Moscow

Ошибок пакетный менеджер не показывает:

Список софта, требующих обновления:

Часовой пояс: UTC + 4 часа

Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot] , Google [Bot]

Источник

Solved Fresh installation — can’t build pkg from ports

===> Building/installing dialog4ports as it is required for the config dialog
===> Cleaning for dialog4ports-0.1.6
===> License BSD2CLAUSE accepted by the user
===> dialog4ports-0.1.6 depends on file: /usr/local/sbin/pkg — not found
===> Skipping ‘config’ as NO_DIALOG is defined
===> License BSD2CLAUSE accepted by the user
=> freebsd-pkg-1.16.3_GH0.tar.gz doesn’t seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://codeload.github.com/freebsd/pkg/tar.gz/1.16.3?dummy=/freebsd-pkg-1.16.3_GH0.tar.gz
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/freebsd-pkg-1.16.3_GH0.tar.gz
=> Couldn’t fetch it — please try to retrieve this
=> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/ports-mgmt/pkg
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/ports-mgmt/pkg
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/ports-mgmt/dialog4ports
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/ports-mgmt/dialog4ports
===> Options unchanged
===> License BSD2CLAUSE accepted by the user
=> freebsd-pkg-1.16.3_GH0.tar.gz doesn’t seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://codeload.github.com/freebsd/pkg/tar.gz/1.16.3?dummy=/freebsd-pkg-1.16.3_GH0.tar.gz
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/freebsd-pkg-1.16.3_GH0.tar.gz
=> Couldn’t fetch it — please try to retrieve this
=> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/ports-mgmt/pkg
*** Error code 1

Stop.
make: stopped in /usr/ports/ports-mgmt/pkg

Источник

How to fix the Runtime Code 1 Adobe Photoshop Lightroom Error 1

This article features error number Code 1, commonly known as Adobe Photoshop Lightroom Error 1 described as Third party payload installer Adobe Photoshop Lightroom 5.pkg failed with exit code: 1.

Error Information

Error name: Adobe Photoshop Lightroom Error 1
Error number: Code 1
Description: Third party payload installer Adobe Photoshop Lightroom 5.pkg failed with exit code: 1.
Software: Adobe Photoshop Lightroom
Developer: Adobe Systems Inc.

This repair tool can fix common computer errors like BSODs, system freezes and crashes. It can replace missing operating system files and DLLs, remove malware and fix the damage caused by it, as well as optimize your PC for maximum performance.

About Runtime Code 1

Runtime Code 1 happens when Adobe Photoshop Lightroom fails or crashes whilst it’s running, hence its name. It doesn’t necessarily mean that the code was corrupt in some way, but just that it did not work during its run-time. This kind of error will appear as an annoying notification on your screen unless handled and corrected. Here are symptoms, causes and ways to troubleshoot the problem.

Definitions (Beta)

Here we list some definitions for the words contained in your error, in an attempt to help you understand your problem. This is a work in progress, so sometimes we might define the word incorrectly, so feel free to skip this section!

  • Adobe — Adobe Systems is a software company headquartered in San Jose, California, USA
  • Exit — Exiting, quitting, or halting refers to the termination of a process or program.
  • Exit code — An exit code is signaled by a program on termination to indicate if it completed successfully, or, if it did not, what sort of failure condition occurred.
  • Installer — GENERAL INSTALLER SUPPORT IS OFF-TOPIC
  • Lightroom — Adobe Photoshop Lightroom provides a comprehensive set of digital photography tools, from powerfully simple one-click adjustments to cutting-edge advanced controls
  • Party — Questions related to the R packages party and partykit for recursive partitioning
  • Payload — The part of the packet, message or code that carries the data
  • Photoshop — Adobe Photoshop is an industry-standard graphics creatoreditor
Symptoms of Code 1 — Adobe Photoshop Lightroom Error 1

Runtime errors happen without warning. The error message can come up the screen anytime Adobe Photoshop Lightroom is run. In fact, the error message or some other dialogue box can come up again and again if not addressed early on.

There may be instances of files deletion or new files appearing. Though this symptom is largely due to virus infection, it can be attributed as a symptom for runtime error, as virus infection is one of the causes for runtime error. User may also experience a sudden drop in internet connection speed, yet again, this is not always the case.

(Adobe Photoshop Lightroom Error 1) Repair Tool»/>
(For illustrative purposes only)

Causes of Adobe Photoshop Lightroom Error 1 — Code 1

During software design, programmers code anticipating the occurrence of errors. However, there are no perfect designs, as errors can be expected even with the best program design. Glitches can happen during runtime if a certain error is not experienced and addressed during design and testing.

Runtime errors are generally caused by incompatible programs running at the same time. It may also occur because of memory problem, a bad graphics driver or virus infection. Whatever the case may be, the problem must be resolved immediately to avoid further problems. Here are ways to remedy the error.

Repair Methods

Runtime errors may be annoying and persistent, but it is not totally hopeless, repairs are available. Here are ways to do it.

If a repair method works for you, please click the upvote button to the left of the answer, this will let other users know which repair method is currently working the best.

Источник

pkg broken after ugrading FreeBSD from 10.1 to 10.2

cellini

when typing the pkg command i get this response

Tried running portmaster -fa

After that you should make sure your ports tree is upto date, your ports-mgmt/portmaster looks seriously out of date because it’s still using the old style package database and not the new pkg database:

make -C /usr/ports/ports-mgmt/portmaster clean install clean

cellini

cellini

But it was missing before the upgrade to, but then pkg was working ?

You were probably upgrading from a very old version of ports-mgmt/pkg that used a statically linked version libucl or it didn’t use it at all. Since your system is missing some crucial system libraries I would reinstall a fresh 10.2. Make a backup of your system first if there’s something important in it now:

Verify that you can restore the backup as well.

cellini

Thanks for all the help, I will do that
I am using zfs and have mirrored my root pool to a block device on my storage pool so everything is copied already.

maquis196

Hi¸ I have the exact same problem but my version of pkg isn’t more then a week or so old since I upgrade often. I’ll try and fix this somehow, hopefully one of my jails is «out-of-date» and can steal some files from there.

Bottom line is, this was working before the 10.2 upgrade, and now it’s not and I’d much rather avoid a fresh install considering what is on the box.

maquis196

pkg-static upgrade -f pkg

The above seems to fix the problem quite nicely. 3 cheers for a static pkg and pint the genius who thought of it!

cellini

venix

talsamon

niklaas

Although I have not upgraded to 10.2 yet and am sticking to my 10.1 installation, I would like add the following: I encountered the error

in one of my jails after upgrading with ezjail-admin update -u . Then freebsd-update install was complaining that it could only upgrade the system partially. I found this thread here https://forums.freebsd.org/threads/ezjail-warning-about-partial-upgrade.52030/#post-297471 and the provided solution only worked partly. Although ezjail-admin update -u was able to update the jails, I still got the error about the missing library.

The only way to solve the problem was by installing the entire basejail again with ezjail-admin install .

Источник

Читайте также:  Java invalid parameter exception
Оцените статью
toolgir.ru
Adblock
detector